$re = '/\-[0-9]+$/mUD';
$str = 'mydomain/mypost-2
http://mydomain/mypost-2
http://mydomain/mypost-234
mydomain/mypost-24';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);