using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z'.]+(?: [a-zA-Z']+)*";
string input = @"John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson
John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson
John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson
Michael Jordan, Shaquile O'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler
Michael Jordan, Shaquile O'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler
Drama, Sci Fi, TV Show, Action
Drama, Action, HORROR, Adventure
Thriller, Mystery, Comedy
Comedy Romance, Action Comedy, CRIME, Sci Fi
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}