import Foundation
let pattern = #"[a-zA-Z'.]+(?: [a-zA-Z']+)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson
John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson
John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson
Michael Jordan, Shaquile O'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler
Michael Jordan, Shaquile O'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler
Drama, Sci Fi, TV Show, Action
Drama, Action, HORROR, Adventure
Thriller, Mystery, Comedy
Comedy Romance, Action Comedy, CRIME, Sci Fi
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)