using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^
(-?) # sign
0* # leading zeros
(
[0-9]+? \. [0-9]*? | # optional decimals
[0-9]*? \. [0-9]+? | # optional wholes
[0-9]* # only wholes
)
0*
$
";
string input = @"-00000100333001001000.00010000000";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}