$re = '/^
(-?) # sign
0* # leading zeros
(
[0-9]+? \. [0-9]*? | # optional decimals
[0-9]*? \. [0-9]+? | # optional wholes
[0-9]* # only wholes
)
0*
$
/x';
$str = '-00000100333001001000.00010000000';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);