use strict;
my $str = '-00000100333001001000.00010000000';
my $regex = qr/^
(-?) # sign
0* # leading zeros
(
[0-9]+? \. [0-9]*? | # optional decimals
[0-9]*? \. [0-9]+? | # optional wholes
[0-9]* # only wholes
)
0*
$
/xp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}