const regex = /^[\p{Z}\p{P}\p{L}\p{N}]+$/mgu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\p{Z}\\p{P}\\p{L}\\p{N}]+$', 'mgu')
const str = `GIORGI SHALAMBERIDZE
გიორგი შალამბერიძე
GIORGI SHALAMBERIDZE 4
გიორგი შალამბერიძე 4
John Doe
Charles III
Sr. Artur
X Æ A-12
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}