$re = '/^[\p{Z}\p{P}\p{L}\p{N}]+$/mu';
$str = 'GIORGI SHALAMBERIDZE
გიორგი შალამბერიძე
GIORGI SHALAMBERIDZE 4
გიორგი შალამბერიძე 4
John Doe
Charles III
Sr. Artur
X Æ A-12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);