// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)^[\p{Z}\p{P}\p{L}\p{N}]+$").unwrap();
let string = "GIORGI SHALAMBERIDZE
გიორგი შალამბერიძე
GIORGI SHALAMBERIDZE 4
გიორგი შალამბერიძე 4
John Doe
Charles III
Sr. Artur
X Æ A-12
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}