use strict;
my $str = 'V1, V2, V3, V4, V5, V6, V7, V8, V9, V10';
my $regex = qr/^.*(?=((,.*){3})$)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";