#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)MyFunction(\((?>\((?<c>)|[^()]+|\)(?<-c>))*(?(c)(?!))\))"
Local $sString = "MyFunction(23)" & @CRLF & _
"MyFunction('Sekret')" & @CRLF & _
"MyFunction( 23, 'Sekret', Date() )" & @CRLF & _
"MyFunction( Encrypt('Sekret'), Date() )" & @CRLF & _
"logger.info("MyFunction( Encrypt('Sekret'), Date() )") " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")