re = /MyFunction(\((?>\((?<c>)|[^()]+|\)(?<-c>))*(?(c)(?!))\))/m
str = 'MyFunction(23)
MyFunction(\'Sekret\')
MyFunction( 23, \'Sekret\', Date() )
MyFunction( Encrypt(\'Sekret\'), Date() )
logger.info("MyFunction( Encrypt(\'Sekret\'), Date() )")
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end