package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/uaa/api/users/[^/]+/city/[^/]+$`)
var str = `/uaa/api/users/john.connor/city/12
/uaa/api/users/john.connor/city/12/
/uaa/api/users///john.connor/city/12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}