$re = '~^/uaa/api/users/[^/]+/city/[^/]+$~m';
$str = '/uaa/api/users/john.connor/city/12
/uaa/api/users/john.connor/city/12/
/uaa/api/users///john.connor/city/12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);