re = /^\/uaa\/api\/users\/[^\/]+\/city\/[^\/]+$/m
str = '/uaa/api/users/john.connor/city/12
/uaa/api/users/john.connor/city/12/
/uaa/api/users///john.connor/city/12'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end