using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A(?=[a-z0-9@.!#$%&'*+\/=?^_`{|}~-]{6,254}\z)
(?=[a-z0-9.!#$%&'*+\/=?^_`{|}~-]{1,64}@)
[a-z0-9!#$%&'*+\/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+\/=?^_`{|}~-]+)*
@ (?:(?=[a-z0-9-]{1,63}\.)[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+
(?=[a-z0-9-]{1,63}\z)[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\z";
string input = @"ragedog@hotmail.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}