import re
regex = re.compile((r"\A(?=[a-z0-9@.!#$%&'*+\/=?^_`{|}~-]{6,254}\z)\n"
r" (?=[a-z0-9.!#$%&'*+\/=?^_`{|}~-]{1,64}@)\n"
r" [a-z0-9!#$%&'*+\/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&'*+\/=?^_`{|}~-]+)*\n"
r"@ (?:(?=[a-z0-9-]{1,63}\.)[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\.)+\n"
r" (?=[a-z0-9-]{1,63}\z)[a-z0-9](?:[a-z0-9-]*[a-z0-9])?\z"), flags=re.MULTILINE)
test_str = "ragedog@hotmail.com"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")