using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*.js|.*android|.*angular.*|.*aws|.*ios|.*js|.*python.*|.*wordpress.*|amazon.*|android.*|angular.*|apple.*|azure.*|c\+\+.*|cakephp.*|cassandra.*|codeigniter.*|drupal.*|facebook.*|google-cloud.*|joomla.*|kentico.*|laravel.*|magento.*|matlab.*|nopcommerce-.*|odoo.*|opencart.*|phpstorm.*|prestashop.*|py.*|python.*|reactjs.*|sap-.*|shopify.*|slack.*|spring.*|swift.*|symfony.*|travis.*|typo.*)";
string input = @"c#
system.text.json";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}