$re = '/(.*.js|.*android|.*angular.*|.*aws|.*ios|.*js|.*python.*|.*wordpress.*|amazon.*|android.*|angular.*|apple.*|azure.*|c\+\+.*|cakephp.*|cassandra.*|codeigniter.*|drupal.*|facebook.*|google-cloud.*|joomla.*|kentico.*|laravel.*|magento.*|matlab.*|nopcommerce-.*|odoo.*|opencart.*|phpstorm.*|prestashop.*|py.*|python.*|reactjs.*|sap-.*|shopify.*|slack.*|spring.*|swift.*|symfony.*|travis.*|typo.*)/m';
$str = 'c#
system.text.json';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);