import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*.js|.*android|.*angular.*|.*aws|.*ios|.*js|.*python.*|.*wordpress.*|amazon.*|android.*|angular.*|apple.*|azure.*|c\\+\\+.*|cakephp.*|cassandra.*|codeigniter.*|drupal.*|facebook.*|google-cloud.*|joomla.*|kentico.*|laravel.*|magento.*|matlab.*|nopcommerce-.*|odoo.*|opencart.*|phpstorm.*|prestashop.*|py.*|python.*|reactjs.*|sap-.*|shopify.*|slack.*|spring.*|swift.*|symfony.*|travis.*|typo.*)";
final String string = "c#\n"
+ "system.text.json";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}