import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^S[BT] [0-9]{7}-0[12]$";
final String string = "SB 0023467-01\n"
+ "ST 0023467-02\n"
+ "SC 0000000-01\n"
+ "SC abcdefg-01\n"
+ "SB 0023467-03";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}