$re = '/^S[BT] [0-9]{7}-0[12]$/m';
$str = 'SB 0023467-01
ST 0023467-02
SC 0000000-01
SC abcdefg-01
SB 0023467-03';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);