import re
regex = re.compile(r"^S[BT] [0-9]{7}-0[12]$", flags=re.MULTILINE)
test_str = ("SB 0023467-01\n"
"ST 0023467-02\n"
"SC 0000000-01\n"
"SC abcdefg-01\n"
"SB 0023467-03")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")