$re = '/(?:\'|").*(?:\'|")/';
$str = 'The sentence is \'He said "Hello there"\'
The sentence is "He said \'Hello there\'"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);