re = /(?:'|").*(?:'|")/
str = 'The sentence is \'He said "Hello there"\'
The sentence is "He said \'Hello there\'"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end