using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:'|"").*(?:'|"")";
string input = @"The sentence is 'He said ""Hello there""'
The sentence is ""He said 'Hello there'""
My text ""can contain"" both single 'and double""' quotes. The quotes ""can also be 'nested"" as you can see.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}