$re = '/(?:\'|").*(?:\'|")/';
$str = 'The sentence is \'He said "Hello there"\'
The sentence is "He said \'Hello there\'"
My text "can contain" both single \'and double"\' quotes. The quotes "can also be \'nested" as you can see.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);