package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?(\d).*(\d).*?(\d).*?(\d).*?(\d).*?$`)
var str = `123456789
1h374jb23j
263jbekwla6892he`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}