re = /^.*?(\d).*(\d).*?(\d).*?(\d).*?(\d).*?$/m
str = '123456789
1h374jb23j
263jbekwla6892he'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end