$re = '/^.*?(\d).*(\d).*?(\d).*?(\d).*?(\d).*?$/m';
$str = '123456789
1h374jb23j
263jbekwla6892he';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);