# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)(.+)(Custom input=.+)/\2/gm;t' <<< "Field 1 : Data
Field 2 : data
Some other data: Data
Some more data = fubar
And yet more information = stuff
And here is more : http://data
Custom input=
Hi there, this is custom input. It may be many paragraphs long, but, it is always until the end of the email itself."