# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)(.+)(Custom input=.+)"
test_str = ("Field 1 : Data\n"
"Field 2 : data\n"
"Some other data: Data\n"
"Some more data = fubar\n"
"And yet more information = stuff\n\n"
"And here is more : http://data\n"
"Custom input=\n"
"Hi there, this is custom input. It may be many paragraphs long, but, it is always until the end of the email itself.")
subst = "\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.