$re = '/(?s)(.+)(Custom input=.+)/m';
$str = 'Field 1 : Data
Field 2 : data
Some other data: Data
Some more data = fubar
And yet more information = stuff
And here is more : http://data
Custom input=
Hi there, this is custom input. It may be many paragraphs long, but, it is always until the end of the email itself.';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;