re = /^4[0-9]{12}(?:[0-9]{3}){0,2}$/m
str = '4111111111111111
4012888888881881
4222222222222
4222222222222881325'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end