// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^4[0-9]{12}(?:[0-9]{3}){0,2}$").unwrap();
let string = "4111111111111111
4012888888881881
4222222222222
4222222222222881325";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}