using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(\d{1,3}\.?(?:\d{1,3}\.?)*)?) ?(\w[\w \t]{4,39})";
string input = @"section
1 section
2. section
2.1 subsection
2.1.1 subsection
2.1.1. subsection
2.1.1. subsection this is a test
2.1.1.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}