re = /^(?:(\d{1,3}\.?(?:\d{1,3}\.?)*)?) ?(\w[\w \t]{4,39})/m
str = 'section
1 section
2. section
2.1 subsection
2.1.1 subsection
2.1.1. subsection
2.1.1. subsection this is a test
2.1.1.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end