import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(\\d{1,3}\\.?(?:\\d{1,3}\\.?)*)?) ?(\\w[\\w \\t]{4,39})";
final String string = "section\n"
+ "1 section\n"
+ "2. section\n"
+ "2.1 subsection\n"
+ "2.1.1 subsection\n"
+ "2.1.1. subsection\n\n"
+ "2.1.1. subsection this is a test\n"
+ "2.1.1. \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}