package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div.*?>([\s\S]*)<\/div>`)
var str = `<div class="my-class additional-class"><div class="my-class2">
<div class="my-class"></div>
</div>
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}