// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<div.*?>([\s\S]*)<\/div>").unwrap();
let string = "<div class=\"my-class additional-class\"><div class=\"my-class2\">
<div class=\"my-class\"></div>
</div>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}