$re = '/<div.*?>([\s\S]*)<\/div>/';
$str = '<div class="my-class additional-class"><div class="my-class2">
<div class="my-class"></div>
</div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);