using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w{3}\s\d.*\d{4}\s\d{2}:\d{2}\w{2}";
string input = @"2359-I need this, date, Apr 11 2013 12:00PM , ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}