re = /\w{3}\s\d.*\d{4}\s\d{2}:\d{2}\w{2}/m
str = '2359-I need this, date, Apr 11 2013 12:00PM , '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end