const regex = new RegExp('\\w{3}\\s\\d.*\\d{4}\\s\\d{2}:\\d{2}\\w{2}', 'gm')
const str = `2359-I need this, date, Apr 11 2013 12:00PM , `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}