using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""POST\"",(?:\""[^\""]+\"",){4}\""(?<my_new_field>[^\""]+)\""";
string input = @"""several fields"",""POST"",""field1"",""fie,ld2"",""field3"",""field4"",""thefieldIwant""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}