// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\"POST\",(?:\"[^\"]+\",){4}\"(?<my_new_field>[^\"]+)\""#).unwrap();
let string = "\"several fields\",\"POST\",\"field1\",\"fie,ld2\",\"field3\",\"field4\",\"thefieldIwant\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}