$re = '/\"POST\",(?:\"[^\"]+\",){4}\"(?<my_new_field>[^\"]+)\"/m';
$str = '"several fields","POST","field1","fie,ld2","field3","field4","thefieldIwant"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);