using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":[^()]+?![^()]+?.tmi.twitch.tv PRIVMSG #[^()]+? :[^()]+?\\r\\n";
string input = @":hey!hey.tmi.twitch.tv PRIVMSG #stream :message here\r\n:otherhey!otherhey!tmi.twitch.tv PRIVMSG #otherstream :othermessage here\r\n";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}