const regex = /:[^()]+?![^()]+?.tmi.twitch.tv PRIVMSG #[^()]+? :[^()]+?\\r\\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':[^()]+?![^()]+?.tmi.twitch.tv PRIVMSG #[^()]+? :[^()]+?\\\\r\\\\n', 'gm')
const str = `:hey!hey.tmi.twitch.tv PRIVMSG #stream :message here\\r\\n:otherhey!otherhey!tmi.twitch.tv PRIVMSG #otherstream :othermessage here\\r\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}