// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):[^()]+?![^()]+?.tmi.twitch.tv PRIVMSG #[^()]+? :[^()]+?\\r\\n").unwrap();
let string = ":hey!hey.tmi.twitch.tv PRIVMSG #stream :message here\\r\\n:otherhey!otherhey!tmi.twitch.tv PRIVMSG #otherstream :othermessage here\\r\\n";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}